A node in our production Kubernetes cluster became unresponsive, causing a brief disruption to some services while workloads were automatically rescheduled to healthy nodes.
The duration of the disruption was about 8 minutes.
Closing this.
Closing the pinned alert on status
All issues affecting uploads to DatoCMS using Cloudflare R2 in the EU region have now been fully resolved.
Uploads are operating normally again across the default EU R2 storage as well as custom storage configurations. We are no longer seeing errors related to this incident.